Fatal error on multisite

Home Forums HRM Fatal error on multisite

Viewing 3 reply threads
  • Author
    Posts
    • #75039
      ajm22
      Participant

      Hi,
      I’ve been facing this error when clicking on HR – Employees on any subsites on a WP multisite install the main site works fine.

      I’ve only set this up in a local environment for testing and tried a number of different ways to troubleshoot it and check for any other known issues online.

      The WeDev plugins are not network activated and each subsite has to activate the plugin,
      all site permalinks are set to %postname%,
      up to date WordPress
      PHP 7.4.1
      MySQL 8.0.16
      Nginx webserver

      Other installed plugins are
      Advanced Custom Fields PRO
      Advanced Custom Fields: Font Awesome
      Ajax Load More
      Breadcrumb NavXT
      Contact Form 7

      I’ve tried uninstalling, reinstalling deleting all the created tables, and still getting the same error any help would be appreciated.

      ( ! ) Fatal error: Uncaught Exception: Table ‘local.wp_2_usermeta’ doesn’t exist in /Users/adam/Local Sites/buildingblocks/app/public/wp-content/plugins/wedevs-project-manager/vendor/tareq1988/wp-eloquent/src/Eloquent/Database.php on line 150
      ( ! ) Illuminate\Database\QueryException: Table ‘local.wp_2_usermeta’ doesn’t exist (SQL: select wp_2_erp_hr_employees.user_id, display_name from wp_2_erp_hr_employees left join wp_users on wp_2_erp_hr_employees.user_id = wp_users.ID left join wp_2_usermeta as gender on wp_2_erp_hr_employees.user_id = gender.user_id and gender.meta_key = ‘gender’ left join wp_2_usermeta as marital_status on wp_2_erp_hr_employees.user_id = marital_status.user_id and marital_status.meta_key = ‘marital_status’ where status = ‘active’ and wp_2_erp_hr_employees.deleted_at is null order by hiring_date desc limit 20 offset 0) in /Users/adam/Local Sites/buildingblocks/app/public/wp-content/plugins/wedevs-project-manager/vendor/tareq1988/wp-eloquent/src/Eloquent/Database.php on line 150

    • #75040
      Mehedi Hasan
      Moderator

      Hello

      WPERP doesn’t support multisite in the network mode. You need to either use it on the single sites or a subsite only in the multisite but not under the network mode.

      Thanks

    • #75041
      ajm22
      Participant

      Thanks for the reply, unless I’m confused about what you’re calling network mode. The plugins are not network activated but installed at a network level and each subsite you would go to plugins > activate to install WPERP all other functionality works fine from what I can see at this stage apart from HR.

    • #76047
      jjlast
      Participant

      yup, getting the exact same error here too. and it’s specifically happening on the “add employee” page. so not able to add any employees to anything.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.